I have come across a few libraries here and there that are still on 1.2(.1). I have upgraded some of them as needed. Are there any libraries you use that you would like to see moved? I ask because I have upgraded a good amount of code from 1.2 to 1.3 (mostly proprietary, but a few free libraries too), and would like to see all the useful libraries be 1.3-compatible. I would be happy to do this (relatively mindless work for the most part, but important) and submit the pull request.

There are some libraries that as far as I can tell are better left behind (because for example they have been superseded by newer libraries that fill the same purpose).

In addition to 3rd-party libs there are also more fka-contrib libs that should probably be upgraded (see http://dev.clojure.org/display/design/Where+Did+Clojure.Contrib+Go) and it might be good to discuss those too.

1 Answers

2
amalloy On

I would be delighted to see Sandbar usable on 1.3 without contrib. The other day I started working on it, but I don't know error-kit well enough to replace his usage of it correctly. Slingshot is the obvious contender, but I introduced a couple test failures that I don't understand by switching to slingshot. I'd love it if you would take a look at my fork and figure out what I've done wrong.