The app crashes on launch when running from XCode 10.2 (before and after Swift 5.0 migration) with this on console

This copy of libswiftCore.dylib requires an OS version prior to 12.2.0.

I understand the error, but not sure what is required to fix this.

3 Answers

5
msk On Best Solutions

Someone in my team fixed the issue. It is a fix in BUCK

providing /usr/lib/swift as a first argument for runtime search paths to linker if iOS >= 12.2, it should load platform libraries.

3
CrazyJoeLv On

Got it fixed in our ObjectiveC-only project by adding empty Swift file. Don't remove it, just keep it there forever!

0
adamup On

For anybody not using BUCK but still experiencing this issue, try adding /usr/lib/swift in your target's Runtime Search Paths (under Build Settings). Instantly fixed things up for me.