Linked Questions

Popular Questions

I just wanted to convert from ImageMagick v7 to ImageMagick v6. while doing that, this error was happened.

bundle install doesn't work correctly.

It seems like json version is something wrong.

How do I fix this error?

Environment below

  1. ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin17]
  2. Rails -v (couldn't find gem) (becuase bundle install can't work)
  3. json list / json (default: 1.8.3) multi_json (1.13.1, 1.11.2, 1.11.0)
  4. Bundler version 1.16.4
  5. Mac Mojave 10.14

when I do bundle install on terminal, then I got this error

Fetching gem metadata from https://rubygems.org/........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies.......
Using rake 12.3.2
Using concurrent-ruby 1.1.4
Using i18n 0.9.5
Fetching json 1.8.6
Installing json 1.8.6 with native extensions
Errno::EPERM: Operation not permitted @ chmod_internal -
/Users/***/projects/***/vendor/bundle/ruby/2.3.0/gems/json-1.8.6/tests/test_json.rb
An error occurred while installing json (1.8.6), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.6' --source 
'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
rails was resolved to 4.2.6, which depends on
actionmailer was resolved to 4.2.6, which depends on
  actionpack was resolved to 4.2.6, which depends on
    actionview was resolved to 4.2.6, which depends on
      rails-dom-testing was resolved to 1.0.9, which depends on
        rails-deprecated_sanitizer was resolved to 1.0.3, which depends on
          activesupport was resolved to 4.2.6, which depends on
            json

I tried to do like this because error statement says Make sure that
gem install json -v '1.8.6' --source 'https://rubygems.org/' succeeds before bundling

but result shows like this

ERROR:  While executing gem ... (Errno::EPERM)
Operation not permitted @ chmod_internal - /Users/***/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/json-1.8.6/tests/test_json.rb

I can't understand this error statement

Errno::EPERM: Operation not permitted @ chmod_internal -

Also, I goggled a lot, then I update commandlinetool follow this https://howchoo.com/g/m2u0mmuwzda/macos-mojave-fix-invalid-active-developer-path

then, I did this command again,

sudo gem install json -v '1.8.6' --source 'https://rubygems.org/'

then, it's completely succeded like this.

Building native extensions. This could take a while...
Successfully installed json-1.8.6
Parsing documentation for json-1.8.6
Installing ri documentation for json-1.8.6
Done installing documentation for json after 1 seconds
1 gem installed

But, if I do bundle install, still doesn't work: they show same error.

Related Questions