This is perfectly fine C# code and works fine provided correct URL. But the everything is just done at one line by reducing the readability of the code.
Here is the code :
return new StreamReader(WebRequest.Create(urlName).GetResponse().GetResponseStream()).ReadToEnd();
I am just wondering what are the opinions of fellow developers on this kind of short cut way of writing code
Push it into a well-named method, and perhaps break it up so that single statment stretches over a couple lines. I'd also probably use WebClient: