so just till 2 days ago there wasn't any problem with my code until yesterday, and I spent 2 days fixing this but no luck

this is my dependencies: all updated

dependencies {
    implementation fileTree(include: '*.jar', dir: 'libs')
    // SUB-PROJECT DEPENDENCIES START
    implementation project(path: ':CordovaLib')
    implementation 'com.android.support:customtabs:28.0.0'
    implementation 'com.android.support:support-v4:28.0.0'
    implementation 'com.facebook.android:facebook-android-sdk:4.42.0'
    implementation 'com.google.gms:google-services:4.2.0'
    implementation 'com.google.android.gms:play-services-tagmanager:16.0.8'
    implementation 'com.google.firebase:firebase-core:16.0.8'
    implementation 'com.google.firebase:firebase-messaging:17.6.0'
    implementation 'com.google.firebase:firebase-crash:16.2.1'
    implementation 'com.google.firebase:firebase-config:16.5.0'
    implementation 'com.google.firebase:firebase-perf:16.2.5'
    implementation 'com.google.android.gms:play-services-maps:16.1.0'
    implementation 'com.google.android.gms:play-services-location:16.0.0'
    implementation 'com.android.support:support-core-utils:28.0.0'
    implementation 'com.google.android.gms:play-services-auth:16.0.1'
    implementation 'com.google.android.gms:play-services-identity:16.0.0'
    implementation 'com.stripe:stripe-android:8.7.0'
    implementation 'com.android.support:appcompat-v7:28.0.0'
    // SUB-PROJECT DEPENDENCIES END
}

buildscript {
    repositories {
        maven { url "https://maven.google.com" }
        google()
        jcenter()
        mavenLocal()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.4.0'
        classpath 'com.google.gms:google-services:4.2.0'
    }
}


allprojects {
    repositories {
        google()
        mavenCentral();
        jcenter()
    }
}

I get this error

Could not find any version that matches com.google.android.gms:strict-version-matcher-plugin:15.+.

and when I run ./gradlew app:dependencies -info

 com.google.gms:google-services:4.2.0
|    \--- com.google.android.gms:strict-version-matcher-plugin:1.1.0 -> 15.+ FAILED
+--- com.google.android.gms:play-services-tagmanager:16.0.8 -> 15.0.2
|    +--- com.google.android.gms:play-services-ads-identifier:[15.0.1,16.0.0) -> 15.0.1 (*)
|    +--- com.google.android.gms:play-services-analytics-impl:[15.0.2] -> 15.0.2

also when I add

apply plugin: com.google.gms.googleservices.GoogleServicesPlugin

to my build.gradle I get a different error

Dependency failing: com.google.android.gms:play-services-auth:15.0.1 -> com.google.android.gms:[email protected][
15.0.1], but play-services-auth-base version was 15.1.0.

The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the art
ifact with the issue.
-- Project 'app' depends onto com.google.android.gms:[email protected]

0 Answers