I install laravel 5.8 on new Ubuntu 16 instance under Digital Ocean. I need to install php 7.2 and for this I run commands:

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update 
sudo apt-get remove php7.0
sudo apt-get install php7.2

I was very surprosed that I found php 7.3:

# php -v
PHP 7.3.5-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: May  3 2019 10:00:05) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.5, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.5-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

After that I got error on composer installing:

# composer  install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file


  [ErrorException]                                                                         
  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?  

Googling I found that it is some specific php7.3 error and I wonder which can be decision here? To downgrade to php7.2(If yes how better to make it?)

Or some other decision ?

Thanks!

0 Answers