My composer.json

...
"require" : {
    "mypackage/mypackage" : "dev-release/3.0.6"
}

A dependency on "mypackage/mypackage" is nowhere else defined in my project.

Runningcomposer update I get the following error:

    - myproject/myproject dev-release/3.0.6 requires mypackage/mypackage ^[email protected] || [email protected] -> satisfiable by mypackage/mypackage[3.0.6.x-dev].
    - myproject/myproject dev-release/3.0.6 requires mypackage/mypackage ^[email protected] || [email protected] -> satisfiable by mypackage/mypackage[3.0.6.x-dev].
    - Conclusion: don't install mypackage/mypackage 3.0.6.x-dev

I do not understand why the first line is a duplicate and what it wants to tell me.

0 Answers