I am building a Swift project using the command line. macOS version is 10.14.5, Xcode version is 10.2.1

When trying to run the generated executable I get: "This copy of libswiftCore.dylib requires an OS version prior to 10.14.4."

Running "otool -L" on the executable I get: "... @rpath/libswiftCore.dylib (compatibility version 1.0.0, current version 1001.0.82) ..."

Running "swift --version" I get: "Apple Swift version 5.0.1 (swiftlang-1001.0.82.4 clang-1001.0.46.5) Target: x86_64-apple-darwin18.6.0"

Running "xcrun swift --version" I get: "Apple Swift version 5.0.1 (swiftlang-1001.0.82.4 clang-1001.0.46.5) Target: x86_64-apple-darwin18.6.0"

Any ideas what can be done to run the generated executable ?

0 Answers