Ancient non CLI ember project

Asked by At

I have a very outdated ember project and I have updated my codebase to use the latest version of jQuery 3.4.0. The problem is, there is deprecated jQuery code in the ember app and it's causing errors. The one error I am seeing is fixHooks. This has long been deprecated in jQuery. However, the ember app is pulling in

cdnjs.cloudflare.com/ajax/libs/ember.js/1.7.0/ember.min.js (Yeah, ancient)

which uses fixHooks.

Do you know of a way or workaround I could do to get this to play nice with the newest version of jQuery?

0 Answers