Usually when there is getter/setter in a POJO class, the general convention I have seen until now was to use return this.<instance variable>
/ this.<instance variable> = something
But, the current project I am working on uses a strange convention of return <class name>.<instance variable>
I understand that this works, but was wondering if this is the right approach at all?